35 lines
1.0 KiB
Nix
35 lines
1.0 KiB
Nix
# To learn more about how to use Nix to configure your environment
|
|
# see: https://developers.google.com/idx/guides/customize-idx-env
|
|
{ pkgs, ... }: {
|
|
# Which nixpkgs channel to use.
|
|
channel = "stable-23.11"; # or "unstable"
|
|
# Use https://search.nixos.org/packages to find packages
|
|
packages = [
|
|
pkgs.nodejs_20
|
|
];
|
|
# Sets environment variables in the workspace
|
|
env = {};
|
|
idx = {
|
|
# Search for the extensions you want on https://open-vsx.org/ and use "publisher.id"
|
|
extensions = [
|
|
# "vscodevim.vim"
|
|
];
|
|
workspace = {
|
|
# Runs when a workspace is first created with this `dev.nix` file
|
|
onCreate = {
|
|
npm-install = "npm install";
|
|
};
|
|
# To run something each time the workspace is (re)started, use the `onStart` hook
|
|
};
|
|
# Enable previews and customize configuration
|
|
previews = {
|
|
enable = true;
|
|
previews = {
|
|
web = {
|
|
command = ["npm" "run" "dev" "--" "--port" "$PORT"];
|
|
manager = "web";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
} |